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Introduction
Enhanced Retirement Plans for Microsoft Dynamics GP consists of four features:
1. Employer Benefit Variable Matching
2. Benefit Group Matching
3. Shared Maximums
4. Retirement Catch Up

Employer Benefit Variable Matching
Employer Benefit Variable Matching is designed to give employers maximum flexibility when matching
the retirement contributions of employees. Companies may create a matching tier that is based on
employee deduction percentages.
Employer Benefit Variable Matching supports Benefit Codes that have a Percent of Deduction method
and a Based On Deduction with a method of Fixed Amount or Gross Wage.

Benefit Group Matching
Group Benefit Variable Matching schedule is designed to give employers maximum flexibility when
matching a group of retirement contributions for employees. Companies may create a matching tier that
is based on employee deduction percentages.
Employer Benefit Variable Matching supports Benefit Codes that have a Percent of Deduction method
and a Based On Deduction with a method of Fixed Amount or Gross Wage.

Shared Maximums
Employees may contribute to more than one retirement plan but still need to comply with IRS regulations
that specify maximum contributions allowable to retirement plans.
Shared Maximums allow companies to specify certain retirement deduction codes as belonging to a
Retirement Code Group. The Retirement Code Group then has a shared maximum, which the employee
deductions will not be allowed to exceed regardless of the individual maximums specified for the
deductions.
Shared Maximums allow companies to specify certain retirement benefit codes as belonging to a Benefit
Code Group. The Benefit Code Group then has a shared maximum, which the employee benefits will not
be allowed to exceed regardless of the individual maximums specified for the benefits.

Retirement Catch Up
Retirement Code Group supports retirement catch up functionality that allows employees to make
additional contributions above the regular maximum once they meet the age criteria.

Quick Setup Steps
The following are the quick reference steps necessary to set up the Enhanced Retirement Plans product
and begin using the features.
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Benefit Variable Matching
If the company is using Payroll only, complete these steps:
1. Check the Variable Matching checkbox in Benefit Setup window to enable the Employer
Maximum Expansion button. The right conditions must be met for variable matching to be
available (see Variable Conditions).
2. On the Benefit Setup window, click the expansion button in the Employer Maximum field to open
the Benefit Variable Matching window and enter the tiers according to the company’s benefit
matching policy.
3. Roll down changes to all maintenance records or access the maintenance records to configure
them individually if applicable.
If the company is using Advanced Human Resources, complete these steps:
1. To create the Percent Benefit Match tiers, open the Benefit Setup window, select the GoTo
button and click Configure Variable Match.
2. Select the Enable Variable Matching checkbox and fill in the employee deduction tiers according
to the company’s benefit matching policy.
3. Select Ok to save the settings and then save the benefit record.
4. Roll down changes to all maintenance records or simply access the maintenance records to
configure them individually if applicable.
5. Setup is complete, variable matching will now process during payroll.

Shared Maximums
If the company is using Payroll only, complete these steps:
1. Open the Retirement Contribution Setup window via Microsoft Dynamics GP > Tools > Setup >
Payroll > Retirement Contribution.
2. In the Retirement Contribution Setup window, create a retirement code group and define a
description.
3. Specify the shared maximum, catch up maximum and minimum age requirements.
4. Assign deduction codes to the retirement code group and save the record.
If the company is using Advanced Human Resources, complete these steps:
1. Open the Retirement Contribution Setup window via Microsoft Dynamics GP > Tools > Setup >
Human Resources > Benefit Deductions > Retirement Plans > GoTo > Retirement Contribution.
2. In the Retirement Contribution Setup window, create a retirement code group and define a
description.
3. Specify the shared maximum, catch up maximum and minimum age requirements.
4. Assign deduction codes to the retirement code group and save the record.
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Retirement Catch Up
1. Open the Retirement Catch Up window to enable catch up retirement contributions for an
employee. To open the window select an employee within the Employee Maintenance window
and click the GoTo menu, select Payroll and click Retirement Catch Up.
2. In the Retirement Catch Up window, select the checkboxes next to the code group for which you
want to enable the catch up provision.
3. Setup is now complete, shared maximums and the retirement catch up provisions will process
during payroll.

Variable Conditions
The variable conditions for Enhanced Retirement Plans product depend upon the following requirements
on the Benefit Setup and Employee Benefit Maintenance windows:
•

Benefit Codes that have a Percent of Deduction method and

•

Based On Deduction with a method of Fixed Amount or Gross Wage.
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Installation Overview
This section will discuss the prerequisites, list the files installed and go through the install process.

Prerequisite
Enhanced Retirement Plans may be used with or without the Human Resource module for Microsoft
Dynamics GP. This document will assume both Payroll and Human Resources modules are installed and
registered. Update Payroll from Human Resources per core functionality.
If the company is using only Payroll or they are using Advanced Human Resources features, see the
appendix.

Install Notes
Prior to installing complete the steps:
•
•
•

Confirm all users are logged out of Microsoft Dynamics GP
Complete all payroll runs and validate no payroll runs are in process
Make a backup of the Company and Dynamics databases

Server/Client
To install Enhanced Retirement Plans downloaded the exe file from our website. Once the files have
been downloaded, you can run them on the Server and/or Client Installations. The product will need to
be installed on all machines that process payroll.
Complete the steps required at the Server and/or Client level to create the necessary Microsoft SQL
Server® Components. Creating the Microsoft SQL Server Components needs to be performed on a
single computer, typically the server.
1. Right click Integrity Data GP2018 Setup.exe file and select “Run as Administrator”. If you do not
see this option, hold the shift key down and right click.
2. Complete the steps in the wizard
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3. Verify the GP directory is correct if it is not select Change
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4. Select Custom to choose to install only the specific products you purchased.
5. Select Activation Components to only install activation manager files. This option will not install
products and it is typically run only to fix an error with activation manager.
6. Select All Components to install all Integrity Data products. The products you did not purchase
will register with a 30-day trial period.
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If you are upgrading you will be prompted to uninstall the older version, select “y”. If you have
multiple products, it will uninstall all products.

7. Select the product(s) to install, if installing multiple products, select all that need to be installed.
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8. Launch Microsoft Dynamics GP 2018.
9. If prompted to include new code, choose yes.
10. Login as the ‘system administrator’ for each company to create the SQL Server components.
11. The system will auto activate the products you have purchased if you have access to the internet
on the machine. If you receive a message Activation Manager failed contact support@integritydata.com and include a screenshot of the Activation Manager window to receive manual keys.

BEST PRACTICES
Install is not a
requirement on the
Server; however it is
recommended.

Install updated version on
previously installed Client
machines.
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Files Installed
GP Folder (C:\Program Files (x86)\Microsoft Dynamics\GP2018
•
•
•
•
•

ERP6491.cnk or ERP6491.dic
Application.IntegrityDataActivation.dll
Integrity.Registration.Constructor.dll
IDA6537.cnk
Integrity.Registration.Addin.dll

Documentation Folder C:\Program Files (x86)\Microsoft Dynamics\GP2018\Documentation
•

Enhanced Retirement Plans User Guide.pdf

Manual Install
If the user encounters errors during the installation, complete the following steps to manually install
Enhanced Retirement Plans:
1. Contact support@integrity-data.com to receive the manual install files for the product(s).
2. Copy and paste the following files into the appropriate locations.
GP Folder (C:\Program Files\Microsoft Dynamics\GP2018)
•
•
•
•
•

ERP6491.cnk or ERP6491.dic
Application.IntegrityDataActivation.dll
Integrity.Registration.Constructor.dll
IDA6537.cnk
Integrity.Registration.Addin.dll

Documentation Folder (C:\Program Files\Microsoft Dynamics\GP2018\Documentation)
•

Enhanced Retirement Plans User Guide.pdf

3. Edit the Dynamics.exe.config
a. Navigate to the GP folder (C:\Program Files\Microsoft Dynamics\GP2018)
a. Backup the Dynamics.exe.config by making a copy and saving the copy **Important**
b. Open Dynamics.exe.config in Notepad
c. Find the <addin> and under <Dynamics> copy and paste the following:
<addin name="IDKeyManagerAddIn"
type="Integrity.Registration.Addin.GPAddIn,Integrity.Registration.Addin,Version=14.0.5.
20297,Culture=neutral,PublicKeyToken=b7ed37edf026e3bc"/>
d. Under <DynamicsGPweb> copy and paste the following:
<addin name="IDKeyManagerAddIn"
type="Integrity.Registration.Addin.GPAddIn,Integrity.Registration.Addin,Version=14.0.5.
20297,Culture=neutral,PublicKeyToken=b7ed37edf026e3bc"/>
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4. Launch Microsoft Dynamics GP.
5. Login as the ‘system administrator’ for each company to create the SQL Server components.

P a g e 15 | 54

Alternate/Modified forms
The system requires using the Enhanced Retirement Plans modified forms for Benefits Setup and
Employee Benefits Maintenance.
Microsoft Dynamics GP > Tools > Setup > System > Alternate and Modified Forms and Reports
1. Select the ID for the user setting up Enhanced Retirement Plans and processing payroll.
If you are not sure which ID to user review the user setup.
2. Select Enhanced Retirement Plans as the product
3. Select Windows as the Type
4. Select All as the Series
5. Expand Benefit Setup
6. Select Enhanced Retirement Plans radial button
7. Select Employee Benefit Maintenance
8. Select Enhanced Retirement Plans radial button
9. Select Save
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Registration
The system will automatically activate the product during the login process. If the activation was
successful, the user will not receive any messages. However, if the activation process was unsuccessful
the user will receive a message. If the activation process fails the user will need to open the Activation
Manager window to activate the product.

Activation Manager
Microsoft Dynamics GP > Tools > Setup > System > Activation Manager

The Site Name defaults from the session information on the About Microsoft Dynamics GP window.
From the Product drop-down list the user may select the product they wish to activate and review
product information. Once the product is selected the following fields will display:
•
•
•

•

Installed Version – Current version number installed.
Enhancement Plan Date – Date of the enhancement plan expiration.
Activation Status – Current status of the product.
o Permanent – Product has been purchased.
o Trial – Product has been issued a trial period.
o Deactivated – Product has been deactivated.
Current Employees – This count defaults from the session information on the About Microsoft
Dynamics GP window. The count does not include inactive employees or employees in a Test or
Historical company. If the current employee count is incorrect validate Test or Historical
companies are named correctly.
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•

Employees Allowed – The number of employees allowed before the product will be inactivated.
If the Current Employees exceeds the Employees Allowed the system will deactivate the product.

The scrolling window contains a list of all companies. By default the product is active for all companies. If
the user would like to inactivate a company unmark the company checkbox.
The Auto Activation option may be selected if the user receives a message at login stating the product is
not activated. When the user selects the Auto Activation option the system will attempt to automatically
activate the product. Once the Auto Activation process is complete the system will display the Activation
Messages. For a detailed list of activation messages see the Activation Manager Messages section.
The Manual Activation option is used to manually enter a token. The user would only manually enter a
token if they were sent a token by Integrity Data.
Select the OK button to close the window.

Test and/or Historical Companies
Registration will not count the active employees in Test or Historical company databases if the Company
Name is named correctly, specifically at the end of the Company Name the user must append the
following: “<TEST>” or “<HISTORICAL>”. See examples below:
•

Dextordinary, Inc. <TEST>

•

Dextordinary, Inc. <HISTORICAL>

To access and modify the Company Name open the Company Setup window via Microsoft Dynamics GP >
Tools > Setup > Company > Company when logged into the Test or Historical Company that needs
modified.

Version Information
To obtain the latest Enhanced Retirement Plans version information, visit our website.
Within Microsoft Dynamics GP verify the version for Enhanced Retirement Plans by selecting the Help
Button, select About Microsoft Dynamics GP and then select the Options button. Click OK until the
Enhanced Retirement Plans window appears.

Version Information
To obtain the latest Enhanced Retirement Plans version information, visit our website.
Within Microsoft Dynamics GP verify the version for Enhanced Retirement Plans by selecting the Help
Button, select About Microsoft Dynamics GP and then select the Options button. Click OK until the
Enhanced Retirement Plans window appears.
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Security Settings
The Security Task Setup window may be used to grant or restrict access to the Enhanced Retirement
Plans windows. To open the window, select the Microsoft Dynamics GP menu, select Tools, select Setup,
select System, select Security Tasks and enter the system password.
1. Select the appropriate Task items. To identify the appropriate task item complete the steps
below:
•

Open the User Security Setup window (Microsoft Dynamics GP > Tools > Setup > User
Security), select the appropriate user and make a note of the Security Role ID assigned to
the user.

•

Open the Security Role Setup window (Microsoft Dynamics GP > Tools > Setup > Security
Roles), select the Role ID that has been assigned to the user and make note of the
Security Task ID assigned to the Role. Use this Task ID to grant security to the Enhanced
Retirement Plans.
NOTE: Enhanced Retirement Plans has a predefined Security Role (RET ADMN) and
Security Task (RET_ADMN_001).

2. Select Enhanced Retirement Plans for the Product.
3. Select Windows for the Type and select 3rd Party for the Series.
4. Use the Access List to grant or restrict access to individual items.
•

To grant or restrict access to an item for this Task ID, click the checkbox to mark or
unmark the item.

•

Click the Mark All button to grant access to all items in the list or click the Unmark All
button to restrict access to all items in the list.

5. Click File > Print to print the Security Task Setup Report for the selected Task ID.
6. Choose OK to save your changes.

Enhanced Retirement Plans > Windows > 3rd Party > Access List
•

APR Main Menu

•

Benefit Group Lookup

•

Benefit Group Matching Setup

•

Contribution Group Lookup

•

Employer Benefit Variable Matching

•

Employer Benefit Variable Matching Maintenance

•

Group Benefit Variable Matching

•

Retirement Catch Up

•

Retirement Contribution Setup
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Enhanced Retirement Plans > Reports > 3rd Party > Access List
•

ERP Retirement Code Groups

•

Enhanced Retirement Plans Retirement Code Groups

When setting up Enhanced Retirement Plans, it is important to make sure appropriate security is set to
the Benefit Setup window.
Use the Alternate/Modified Forms and Reports window to set Enhanced Retirement Plans for the Benefit
Setup and Employee Benefit Maintenance windows. To open the window, select the Microsoft Dynamics
GP menu, select Tools, select Setup, select System, select Alternate/Modified Forms and Reports and
enter the system password.
1. Select the appropriate ID. To identify the appropriate ID complete the steps below:
•

Open the User Security Setup window (Microsoft Dynamics GP > Tools > Setup > User
Security), select the appropriate user and make a note of the Alternate/Modified Forms
and Reports ID assigned to the user.

2. Select All Products for the Product.
3. Select Windows for the Type.
4. Within the Alternate/Modified Forms and Reports List expand Payroll, expand:
•

Benefit Setup

•

Employee Benefit Maintenance

then select Enhanced Retirement Plans.
5. Employee Benefit Maintenance
6. Click Save to save the changes.
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Security Task
The following windows will be assigned to the RET_ADMN_001* task:
•
•
•
•
•
•

Employer Benefit Variable Matching
Employer Benefit Variable Matching (HR Retirement Plans Setup Alternate)
Retirement Catch Up
Retirement Contribution Setup
Benefit Group Matching Setup
Group Benefit Variable Matching

The following reports will be assigned to the RET_ADMN_001* task:
•
•

Retirement Code Groups
Benefit Code Group Report

The following tasks will be assigned to the RET ADMN Role:
•

RET_ADMN_001* task
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Employer Benefit Variable Matching
Microsoft Dynamics GP > Tools > Setup > Human Resources > Benefits & Deductions > Retirement Plans >
GoTo > Benefit Variable Matching
Use the Employer Benefit Variable Matching window to set up a matching tier that allows the employer
to dynamically define the benefit amount.
To open the Employer Benefit Variable Matching window, within the Navigation Pane select HR & Payroll.
In the Content Pane, select Setup. Under the heading Human Resources, select Benefits and Deductions
and then click Retirement Plans. Within the Retirements Plans Setup window, click the GoTo button and
click Benefit Variable Matching.

Enable Variable Matching checkbox – select to enable variable matching for the specified benefit code.
Benefit Code & Description – default from the Retirement Plans Setup window and are read-only.
Match Method– select a range to configure the employer benefit variable matching and based on
definitions.
•
•

Use Single Range allows the benefit to be calculated for the tier range in which the effective
deduction amount falls into the percentage benefit or fixed benefit match amount.
Cumulative Range Sum allows the benefit to sum an entire benefit amount then calculates each
tier range and then sums the percentage benefit or fixed benefit match amount to define the
total benefit amount for the employee.
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Match Based On – select a based on deduction option to configure the employer benefits variable
matching and based on definitions. NOTE: Gross Wage is defined as the deduction and/or benefit “based on
wages”.
This document includes six different business scenarios for Employer Benefit Variable Matching:
•
•
•
•
•
•

Use Single Range match based on Deduction
Use Single Range match based on Gross Wages
Use Single Range match based on Fixed Amount
Cumulative Range Sum match based on Deduction
Cumulative Range Sum match based on Gross Wages
Cumulative Range Sum match based on Fixed Amount

From & To – define the tier for the employee deduction. If the deduction falls within the employee
deduction tier then the system will match according to what is in the Percent Benefit Match or Fixed
Benefit Match field.
Percent Benefit Match –enter the percentage the employer will match against the employee deduction in
the From & To tiers specified.
Fixed Benefit Match – enter the fixed benefit amount the employer will match based on the effective
deduction percentage within the From & To tiers specified.
The last percent defined in the To field is essentially the highest tier where employer matching applies
and reflects the employer maximum. This percentage is reflected in the Employer Maximum field on the
Employee Benefit Maintenance and Benefit Setup windows.
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Benefit Group Matching Setup
Microsoft Dynamics GP > Tools > Setup > Payroll > Benefit Group Matching Setup
This window allows the user to establish Benefit Code Groups by assigning selected benefit codes to the
group. The group can be assigned a specific shared maximum amount and group matching schedule.
The system allows the user to specify employer benefit matching setup information with the following
fields:
•
•
•
•

Benefit Code Group
Description
Shared Maximum
Use Group Matching

Benefit Code Group – creates a new benefit code group or selects an existing benefit code group.
Description – enter a description for the new benefit code group or if recalling an existing benefit code
group the description will prefill.
Shared Maximum – enter a maximum dollar amount shared between benefits for a calendar year.
Use Group Matching checkbox – will enable the Schedule button. When the Schedule button is selected
the Group Benefit Variable Matching window is opened.
Schedule – the system provides the user the ability to assign a variable matching schedule to a benefit
code group. This group schedule will be applied to all benefits selected for the group and will replace
benefit maintenance setups.
This document includes two different Group Benefit Variable Matching scenarios:
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•
•

Benefit Group Matching Scenario
Benefit Group Matching Utilizing Shared Maximum Scenario
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Shared Maximums
Microsoft Dynamics GP > Tools > Setup > Human Resources > Benefits & Deductions > Retirement Plans >
GoTo > Retirement Contribution
The Retirement Contribution Setup window is used to configure the features for shared maximums and
catch up provisions for retirement plan deductions.
To open the Retirement Contribution Setup window, within the Navigation Pane select HR & Payroll. In
the Content Pane, select Setup. Under the heading Human Resources, select Benefits and Deductions
and then click Retirement Plans. Within the Retirements Plans Setup window, click the GoTo button and
click Retirement Contribution.

Retirement Code Group – create a code to bundle different deduction codes together that will share a
common maximum deduction amount.
Description – enter a description to reference the Retirement Code Group. The field does not affect
functionality.
Shared Maximum – enter a maximum dollar amount for the code group. In the illustration above, the
amount is set to $18,000.00. All the codes assigned to the group are subject to the shared maximum as
well as the individual maximums defined for the codes themselves. Thus, during the year if an employee
contributes to several retirement plans, the system will cease the deductions for those plans once the
employee has contributed $18,000.00 total. The system will stop the deductions even if the individual
limits were not reached because all of the codes together have collectively reached the $18,000.00.
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Catch Up Maximum – enter a limit to the amount an employee is able to contribute beyond the normal
Shared Maximum, see illustration above. In the illustration, $6,500.00 will be added to the shared
maximum an employee could contribute across ALL deduction codes that belong to the code group.
Thus, the new limit would be $24,500.00
for the code group. Specifying an amount
in the field does not guarantee that an
Although an employee may be eligible for the
employee with retirement codes
catch up provision, it does not follow that the
belonging to the group will be allowed to
system will automatically apply the new limit. The
exceed the normal shared limit. An age
user must specify which employees are utilizing the
criterion must be fulfilled (see Catch up
catch up feature (see Retirement Catch Up).
Minimum Age).
Catch Up Minimum Age – defines the age
an employee must be in order to be eligible for the catch up limit provision. The system looks at the birth
date of the employee and determines if that employee is or will turn the appropriate age during the
current calendar year. In the above illustration, if an employee is 55 years of age or will turn 55 during the
current calendar year the system will consider that employee eligible for the catch up provision.

Designate Code Group
Deduction Code & Selected for Group – The user
selects a code from the list of Deduction Codes
section and then inserts them into the Selected for
Group section. There may be one or more codes
selected.

The system prevents the user from assigning a
deduction code to more than one group. In
the illustration above, the code 401KR could
not belong to another code group until it is
removed from this 401K group.
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Retirement Catch Up
Microsoft Dynamics GP > Cards > Payroll > Employee > GoTo> Payroll > Retirement Catch Up
The Retirement Catch Up window is used to enable the catch up provision for individual employees. The
scrolling window displays all the codes groups, the related descriptions and minimum age requirements.
To open the Retirement Catch Up window, within the Navigation Pane select HR & Payroll. In the Content
Pane, select Cards. Under the heading Payroll, select Employee and then click the GoTo button and click
Retirement Catch Up.

Employee ID & Name –fields are display only and default the information from the Employee
Maintenance record.
Enable Catch Up – if this checkbox is selected, the system performs a check to make sure the individuals
age is eligible for the given code group listed.
Since all code groups are listed, it is possible that an employee can have catch up enabled for a code
group that contains deduction codes the employee does not have. Although the payroll process is
unaffected, it is important to note the following:
If an employee has enabled the catch up provision for a code group and later obtains deduction
codes that are members of that code group, the catch up will apply automatically without user
intervention. In effect, the employee has been pre-enabled for a code group that takes effect
when the employee is assigned a deduction in the code group.
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Retirement Catch Up Mass Update
Microsoft Dynamics GP > Tools > Routines > Payroll > Retirement Catch Up Mass Update
The Retirement Catch Up Mass Update window is used to mass enable the catch up provision for multiple
employees. An employee may be enabled for catch up if they meet the catch up minimum age and are
assigned to at least one of the deduction codes within a retirement code group.
To open the Retirement Catch Up Mass Update window, within the Navigation Pane select HR & Payroll.
In the Content Pane, select Routines. Under the heading Payroll, select Retirement Catch Up Mass
Update.

Retirement Code Group – Select the Retirement Code Group to enable catch up for employees assigned
to a deduction within the group.
Catch Up Minimum Age –displays the age from the Retirement Contribution setup.
Age As of Date – Enter the date used to determine the employees age. For example, if an employee must
be 55 by the end of the calendar year to qualify for catch up then select 12/31 of the appropriate year as
the date.
Show All – Displays all employees eligible for catch up.
Show Unassigned – Displays only eligible employees who are not assigned to catch up.
Enable Catch Up – Select Mark All or a specific employee to enable catch up for the employee.
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Retirement Code Group Report
Selecting the print button on the Retirement Contribution Setup window will generate the Retirement
Code Group Report that allows the user to see which codes are contained in the various code groups,
along with other detail as depicted below.

When a catch up maximum is applied to a code group, the amount of the maximum specified will
be added to the maximum defined for the deduction codes as well as the shared maximum. The
actual maximum specified in the deduction maintenance records will not be altered but the system
will simply allow the employee deduction to exceed the maximum defined for the deduction by the
amount of the catch up maximum. This will occur unless the employee has disabled the catch up
maximum provision.
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Benefit Code Groups Report
Selecting the print button on the Benefit Group Matching Setup window will generate the Benefit Code
Groups Report that allows the user to see which codes are contained in the various code groups, along
with other detail as depicted below.
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Appendix A:
Payroll Only - Employer Benefit Variable Matching
Benefit Setup Window
Microsoft Dynamics GP > Tools > Setup > Payroll > Benefit
The Enhanced Retirement Plans feature supports variable benefit matching for employers, which may be
configured from the Benefit Setup Window.
To open the Benefit Setup window, in the Navigation Pane select HR & Payroll. In the Content Pane,
select Setup. Under the heading for Payroll, select Benefit.

Benefit Tiers
•

Percent Field – is disabled and cleared because the amount the employer matches depends upon
the Employer Benefit Variable Matching tier.

•

Variable Matching checkbox – selecting this checkbox activates variable matching by enabling the
Employer Maximum Expansion Button for configuration. Notice that Employer Maximum field is
disabled. This is because the maximum depends upon the Employer Benefit Variable Matching
tier that is configured. This field, though disabled, displays the maximum according to the tier
once configured.

Employer Maximum
•

Expansion Button – click to open the Benefit Variable Matching window. Use the Benefit Variable
Matching window to configure the custom matching tier.
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Variable Matching with Fixed Amounts
As part of the variable matching feature, users may apply their custom variable matching tier to an
employee who has a fixed amount deduction in place for his retirement plan. The system processes the
matching differently in the background by converting the fixed amount to a percentage that can be used
by the variable matching tier. The result is that the variable matching feature is still using a percentage to
determine where in the range of the custom tier it falls. This allows for accurate matching for the benefit.

Employer Benefit Variable Matching Window
Microsoft Dynamics GP > Tools > Setup > Payroll > Benefit > Employer Maximum (expansion button)
The Employer Benefit Variable Matching Window is used to set up a matching tier that is dynamic and
dependent upon what the employee contributes via his deduction.
To open Employer Benefit Variable Matching window, in the Navigation Pane select HR & Payroll. In the
Content Pane, select Setup. Under the heading for Payroll, select Benefit and then select the Employer
Maximum (expansion button).
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Employee Benefit Maintenance Window
Microsoft Dynamics GP > Cards > Payroll > Benefit
Use the Employee Benefit Maintenance window to assign the benefit code. While it is possible to
configure Employer Variable Matching at the employee level, it is not recommended, it may result in
employees having different matching rules for the same type of retirement plan. This could have an
impact on legal and accounting issues regarding matching regulations.
To open the Employee Benefit Maintenance window, in the Navigation Pane select HR & Payroll. In the
Content Pane select Cards. Under the heading for Payroll, select Benefit.

Benefit Tiers
•

Percent Field – defaults the percentage from the Benefit Setup window.

•

Variable Matching checkbox – defaults from the Benefit Setup window.

Employer Maximum
•

Expansion Button – click to open the Benefit Variable Matching window. The information is
defaulted from the Benefit Setup window.
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Employer Benefit Variable Matching Scenarios
This section includes six different business scenarios. Each scenario has different Match Method and
Match Based On options select. These scenarios as explain the calculation process.

Use Single Range match based on Deduction Scenario
Fabrikam, Inc.’s 401K plan states “The more you contribute, the more the company matches!” An
employee who contributes up to 2%, the employer matches 25% of the contribution. From 2% to 4%, the
employer will match 50%. Between 4% and 6% the employer will match dollar for dollar for a 100%
match. For 6% - 10% the employer actually contributes more than the employee does, at 125% match!
Anything over 10% the employer is matching at 150%. The whole point of incentive plan is to have higher
matches for the whole contribution amount. That way if an employee contributes 11% for example, the
whole 11% is matched at 150% instead of breaking the 11% into pieces and matching them each
different according to the scale.
This employee contributes 4.5% of gross wages and has a total of $1,500 in gross wages.
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The system calculates the employee deduction and employer benefit as:

Employee Deduction Calculation:
4.5% multiplied by $1,500 (GW)

=

$67.50

Employee Deduction Amount

$67.50

Employer Benefit Calculation:
4.5% matched at 100.00% multiplied by $1,500 (GW)

=

$67.50

Employer Benefit Amount

$67.50
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Use Single Range match based on Gross Wages Scenario
Fabrikam, Inc.’s 401K plan opted for a gross wage approach where any contribution between 0 – 6% is
matched at 2% of gross wages. Anything between 6% - 10% contribution by the employee, the company
then matches 5% of gross wages. If the contribution is beyond 10% then the company matches at 10%.
This employee contributes 7% of gross wages and has a total of $1,500 in gross wages.
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The system calculation the
employee deduction and employer
benefit as:

Employee Deduction Calculation:
7% multiplied by $1,500 (GW)

=

$105.00

Employee Deduction Amount

$105.00

Employer Benefit Calculation:
5% matched multiplied by $1,500 (GW)

=

$75.00

Employer Benefit Amount

$75.00
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Use Single Range match based on Fixed Amount Scenario
Fabrikam, Inc. experienced enthusiasm for its retirement plan with many employees contributing more
than 6%. The current method of matching every tier has run up the cost of the benefit so beginning next
year Fabrikam will change the rules. A match will no longer be cumulative. The employee will still get
more for contributing more, but the compounding will be eliminated. The employee gets $100 plus $20
extra for each percent thereafter.
This employee contributes 2.5% of gross wages and has a total of $1,500 in gross wages.

The system calculation the employee
deduction and employer benefit as:
Employee Deduction Calculation:
2.5% multiplied by $1,500 (GW)

=

$37.50

Employee Deduction Amount

$37.50

Employer Benefit Calculation:
2.5% employee deduction

=

$140.00

Employer Benefit Amount

$140.00
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Cumulative Range Sum match based on Deduction Scenario
Fabrikam, Inc.’s 401K plan is set up as the company will match an employee’s contribution dollar for dollar
up to 3% contribution by the employee. After 3% the employee can contribute more but the company
only matches a part of the contribution. Between 3% and 4% the company will match half of the
employee’s contribution. Between 4% and 6% the company will only match a quarter of the contribution.
After 6% the company stops matching all together.
This employee contributes 4.5% and has a total of $1,500 in gross wages.
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The system calculates the employee deduction and employer benefit as:

Employee Deduction Calculation:
4.5% multiplied by $1,500 (GW)
Employee Deduction Amount

=

$67.50
$67.50

Employer Benefit Calculation:
3% multiplied by 100% multiplied by $1,500 (GW)

=

$45.00

+

1% multiplied by 50% multiplied by $1,500 (GW)

=

$7.50

+

.5% multiplied by 25% multiplied by $1,500 (GW)

=

$1.88

Employer Benefit Amount

$54.38
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Cumulative Range Sum match based on Gross Wage Scenario
Several years later, Fabrikam, Inc. experiences exponential growth. Instead of implementing a profit
sharing program, the company decides to modify the employee retirement matching. As a result,
Fabrikam decided to reward its employees by using the exact same structure as before with the
exception that the matching was stackable. Now employees who contribute large sums to their
retirement accounts and cross several tiers are matched on every tier! So someone contributing 16% of
their income to their retirement would be matched with 2% + 5% + 10% for a total of a 17% match by the
company!
This employee contributes 16% and has a total of $1,500 in gross wages.
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The system calculation the employee deduction and employer benefit as:

Employee Deduction Calculation:
16% multiplied by $1,500 (GW)
Employee Deduction Amount

=

$240.00
$240.00

Employer Benefit Calculation:
0%-6% range – 2% multiplied by $1,500 (GW)

=

$30.00

+

6.01%-10.00% – 5%multiplied by $1,500 (GW)

=

$75.00

+

10.01% – greater – 10% multiplied by $1,500 (GW)

=

$150.00

Employer Benefit Amount

$255.00
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Cumulative Range Sum match based on Fixed Amount Scenario
Fabrikam, Inc. is a small company with cash flow issues. Their 401k plan is limited in its ability to match
contributions by employees. Therefore the plan states to limit the exposure by allocating a fixed amount
for benefits and have implemented a graduated scale. Anyone who contributes to the 401K up to a least
1% gets $100. Thereafter, each employee gets $50 for every 1% they contribute.

This employee contributes 2.5% and has a total of $1,500 in gross wages.
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Employee Deduction Calculation:
2.5% multiplied by $1,500 (GW)
The system
employee
employer

Employee Deduction Amount

=

$37.50
calculation the
deduction and
benefit as:

$37.50

Employer Benefit Calculation:
0%-1% range

=

$100.00

+

1.01%-2.0% range

=

$50.00

+

2.01% – 3.0% range

=

$50.00

Employer Benefit Amount

$200.00
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Group Benefit Variable Matching Scenarios
This section includes two different business scenarios for group matching. These scenarios as explain the
calculation process.

Benefit Group Matching Scenario
Pilar Ackerman participates in the 401K plan at Fabrikam, Inc. and she has 6% deducted from her
paycheck. She receives a 4% match according to company policy given her level of participation.

Pilar is a government employee which enables her to participate in the 457 program as well. She has 1%
deducted from her check to participate in that program and receives a 2% match.
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To comply with internal business rules limiting the amount of benefit the company is liable for, Fabrikam,
Inc. has grouped these benefits together in a benefit group called “RETGRP” and set the maximum to
$15,000.00.
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Normally, company matching would be conducted as per the schedule defined for each benefit. That
would yield a 6% total match for the 7% of her check Pilar is contributing. But, Fabrikam, Inc. has decided
to apply a different matching schedule for cases where an employee is enrolled in two retirement
programs simultaneously.
The user can utilize the Group Benefit Variable Matching option by selecting the Use Group Matching
checkbox on Benefit Group Matching Setup window and then select the Schedule button in order to
specify their matching ranges on the Group Benefit Variable Matching window.
Under this scenario Pilar actually gets more of a match for her 7% contribution. The schedule dictates she
gets a 10% of gross wage match.

This latest paycheck was for $2,600 gross wages, which would dictate a $260 match for Pilar. This $260
must now be allocated to the two programs she is participating in. When a benefit group has variable
group matching enabled and schedule defined, the amount of the match is prorated across all benefits of
the group. How much gets allocated depends on the ratio of the deductions on the paycheck. Thus if
Pilar had participated in each program equally on the deduction side, the benefit would have been split
50/50 among the programs on the benefit side.
However in this scenario, Pilar’s deductions were 6% for 401K and 1% for 457. This is a total of 7%, so
6/7ths of the benefit will go to the 401K and 1/7th of the benefit will go to the 457. So the $260 is split
$222.80 for 401K and $37.20 for 457 when it comes time to allocate the benefits.
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Note that it does not matter that the individual matching on those benefits were 4% and 2% respectively.
When they belong to a group with variable matching schedule assigned to the group, then the benefit is
split according to a ratio derived by looking at how Pilar’s deduction percentages are related to each
other. (ie… 6/7 and 1/7). As long as the $260 didn’t violate the $15,000 yearly max for the group, Pilar
should get the full benefit according to the proration.

Employee Deduction Calculation:
7% multiplied by $2,600 (GW)
Employee Deduction
Amount

= $182.00
$182.0

Employee Deduction Percentage Calculation:
401K (6%) + 457 (1%) = Effective Deduction 7%
Employer Benefit Calculation:
10% multiplied by $2,600 (GW)

=

$260.00

Employer Benefit Amount

$260.00
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Benefit Group Matching Utilizing Shared Maximum Scenario
Using the same details from the scenario above; however, the next $260 match exceeds the $15,000 max
by $60, which leaves $200 to be allocated across the two benefits. Recalculating 6/7 and 1/7 of $200 will
give the proper amount for Pilar’s benefit.

Employee Deduction percentage Calculation:
401K (6%) + 457 (1%) = Effective Deduction 7%
Employer Benefit Calculation:
10% multiplied by $2,600 (GW)

=

$260.00

+

Calendar Year Benefit Amount

=

$14,800.00

-

Shared Maximum

=

$15,000.00

Employer Benefit Amount

$200.00

Employee Deduction Calculation:
7% multiplied by $2,600 (GW)
Employee Deduction Amount

=

$182.00
$182.00
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Activation Manager Messages
Activation Failed: Trial invalid or trial period expired
Situation: The trial period has expired for the product.
Solution: Contact sales@integrity-data.com and request additional trial period or purchase the product.

Activation Failed: Site name does not match this installation
Situation: The site name does not match the token which was issued.
Solution: Send support@integrity-data.com a screenshot of the Activation Manager window with the
error message displayed so the token can be updated with the correct site name.

Activation Failed: Product Name does not match this installation
Situation: The product name does not match the token which was issued for a product.
Solution: Send support@integrity-data.com a screenshot of the Activation Manager window with the
error message displayed so the token can be updated with the correct site name.

Trial period for Enhanced Retirement Plans has expired
Situation: The trial period has expired for the product.
Solution: Contact sales@integrity-data.com and request additional trial period or purchase the product.

Employees Allowed has been exceeded
Situation: The current employee count has exceeded the employees allowed.
Solution: Contact sales@integrity-data.com to upgrade to the next tier.

Activation Failed: Unable to contact web service. Activate manually or revert to
previous product dictionary
Situation: The system could not make a connection to the web service.
Solution: Contact support@integrity-data.com for assistance.

Activation Failed: Product has been deactivated
Situation: The product has been deactivated.
Solution: Contact support@integrity-data.com for assistance.

Upgrade Failed: Enhancement Plan period expired. Renew Enhancement Plan or
revert to previous product version.
Situation: User attempted to upgrade a product when their enhancement plan was expired.
Solution: Contact sales@integrity-data.com to renew the enhancement plan.

Enhanced Retirement Plans: Activation Failed
Situation: Communication breakdown between the user machine and Integrity Data.
Solution: Contact support@integrity-data.com for assistance.

P a g e 51 | 54

Deactivate Product
There are three ways to deactivate the Enhanced Retirement Plans; disable, inactive or uninstall.

Disable
To disable Enhanced Retirement Plans without having to exit Microsoft Dynamics GP, open the
Customization Status window. To open this window, select the Microsoft Dynamics GP menu, point to
Tools, select Customize and then click Customization Status. Select the product from the list and click
Disable. The product can be enabled by closing and reopening Microsoft Dynamics GP.

Inactivate
Enhanced Retirement Plans can be inactivated by company, open the Activation Manager window and
unmark the company checkbox.

Uninstall
If Enhanced Retirement Plans needs to be uninstalled complete these steps on the server and the client
where Enhanced Retirement Plans has been installed.
1. Remove the ERP.DIC file from the Runtime Directory
Default location is C:\Program Files\Microsoft Dynamics\GP2018
2. Make a copy of the Dynamics.set file
3. Open the Dynamics.set file
a.

Decrease the top number by one:
For example, if the top number is 21 change it to 20
b. Remove the following lines from the Dynamics.set file:
6491
Enhanced Retirement Plans
:C:Program Files (x86)/Microsoft Dynamics/GP/ERP.DIC
:C:Program Files (x86)/Microsoft Dynamics/GP/Data/F6491.DIC
:C:Program Files (x86)/Microsoft Dynamics/GP/Data/R6491.DIC

4. Save the Dynamics.set file
5. Launch Microsoft Dynamics GP and login as the ‘system administrator’
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Uninstall Activation Manager
Activation Manager will manage activation for all Integrity Data Products. If you are uninstalling all
Integrity Data products, you need to remove the Activation components.
IMPORTANT: If you uninstall one product but have other Integrity Data products do not uninstall the
Activation Manager components.
1. Make a copy of the Dynamics.set file
2. Open the Dynamics.set file
a. Decrease the top number by one:
For example, if the top number is 21 change it to 20
b. Remove the following lines from the Dynamics.set file:
6537
Integrity Data Activation
:C:Program Files (x86)/Microsoft Dynamics/GP2013/IDA6537.DIC
:C:Program Files (x86)/Microsoft Dynamics/GP2013/Data/IDA6537F.DIC
:C:Program Files (x86)/Microsoft Dynamics/GP2013/Data/IDA6537R.DIC
1. Save the Dynamics.set file
Make a copy of the Dynamics.exe.config file.
3. Edit Dynamics.exe.config and find the line(s) beginning with:
<addin name=”IDKeyManagerAddin”
4. Remove the lines from both the <Dynamics> and <DynamicsGPWeb> sections.
5. Save the Dynamics.exe.config file
6. Launch Microsoft Dynamics GP and login as the ‘system administrator’
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Contact Information
Get quick answers to your questions
Browse our convenient Knowledge Base for up-to-date answers to the most common questions. For
additional questions, please contact your authorized Value Added Reseller (VAR) for support on this
product (if you have one) or contact Integrity Data by emailing support@integrity-data.com or calling
888.786.6162.
If you have registered your product, Technical Customer Service is available for any customers with a
current Enhancement Plan or subscription. Please have your Company or Site Name available. Your first
line of support should always be your VAR (if you have one).
Join our User Groups
We have an HR and payroll focused one and an ACA one – email lbelley@integrity-data.com to join!
Rate us and our products
Are you pleased with your experience with us and our products? Provide a quote and get a gift card! Fill
out the form on our contact page and leave your quote in the comment section.
Suggest new features or improvements
User input into improving this product and constructive feedback are appreciated. Please e-mail Tom, our
Director of Client Services, at tfranz@integrity-data.com or David, our Product Manager at
dwilmert@integrity-data.com. As always, technical ideas and user input are highly encouraged. At
Integrity Data, we want to hear your input, so drop us a line!
Browse our solutions
The Integrity Data website is a great place to get additional information on products and services. The
following information is available on our website:
•
•

Integrity Data’s HR & Payroll software pages include Demos, Features and Benefits, and ROI
Calculators
Visit our Services page to learn more about our additional customization services

If you would like to discuss your needs with a Sales Account Executive, please call 888.786.6162 or e-mail
sales@integrity-data.com.
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