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Installation Overview  

This section will discuss the prerequisites, list the files installed and go through the install process.  

Prerequisite  
The Employee E-Mail Suite consists of two modules that provide additional capabilities for an existing 

Microsoft Dynamics GP installation: Employee E-Mail Suite and E-Mail W-2 Statements. 

The prerequisites for the Employee E-Mail Suite: 

¶ Microsoft Dynamics GP Payroll 

¶ Direct Deposit 

¶ .NET Framework 3.5 or above 

¶ Adobe Acrobat Standard X, XI or DC 

¶ E-Mail Sending Options  

o Microsoft Outlook 2010 or 2013 

Requires installing Integrity Email Addin and Visual Studio Tools for Office 

o SMTP Server 

Install  Notes   
Prior to installing validate the steps: 

¶ Confirm all users are logged out of Microsoft Dynamics GP 

¶ Complete all payroll runs and confirm no payroll runs are in process 

¶ Make a backup of the company and Dynamics databases 
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Server /Client  
To install Employee E-Mail Suite downloaded the exe files from our website Once the files have been 

downloaded, you can run them on the Server and/or Client Installations. The product will need to be installed 

on all machines that process payroll.    If you will send with using Microsoft Outlook then download the 

Outlook Setup.exe in addition to the Integrity GP 2013 Setup.exe 

 

Complete the steps required at the Server and/or Client level to create the necessary Microsoft SQL Server® 

Components.  Creating the Microsoft SQL Server Components needs to be performed on a single computer, 

typically the server. 

1. Right click Integrity Data GP2013 Setup.exe file and select ®Run as Administrator¯.  If you do not see 

this option, hold the shift key down and right click. 

2. Complete the steps in the wizard 

 

http://www.integrity-data.com/hrp/product-download-form/0310360942-2/
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3. Verify the GP directory is correct if it is not select Change 

 

4. Select Custom to choose to install only the specific products you purchased.   
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5. Select Activation Components to only install activation manager files.  This option will not install 

products and it is typically ran only to fix an error with activation manager. 

6. Select All Components to install all Integrity Data products.  The products you did not purchase will 

register with a 30-day trial period.   

 

If you are upgrading you will be prompted to uninstall the older version, select y. If you have multiple 

products, it will uninstall all products. 

 

7. Select the product(s) to install, if installing multiple products, select all that need to be installed. 
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8. Launch Microsoft Dynamics GP 2013. 

9. If prompted to include new code, choose yes. 

10. Login as the ¬system administrator­ for each company to create the SQL Server components. 

11. The system will auto activate the products you have purchased if you have access to the internet on 

the machine.  If you receive a message Activation Manager failed contact support@integrity-data.com 

and include a screenshot of the Activation Manager window to receive manual keys. 

 

 

  

BEST PRACTICES 

Install is not a requirement 
on the Server; however it is 

recommended. 

Install updated version on 
previously installed Client 

machines. 
 

 

mailto:support@integrity-data.com
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Files Installed  
GP Folder (C:\Program Files\Microsoft Dynamics\GP2013) 

¶ EES.cnk  

¶ EES.chm  

¶ Application.EmployeeEmailSuite.dll 

¶ IDA6537.cnk  

¶ Application.IntegrityDataActivation.dll  

¶ Integrity.Registration.Constructor.dll  

¶ itextsharp.dll  

¶ Integrity.Email.Addin.dll  

¶ Microsoft.Office.Interop.Outlook.dll  

¶ Integrity.Registration.Addin.dll  

Documentation Folder (C:\Program Files\Microsoft Dynamics\GP2013\Documentation) 

¶ Employee E-Mail Suite GP 2013 User Guide.pdf  

W2-Attach Folder (C:\Program Files\Microsoft Dynamics\GP2013\Data\W2-Attach) 

¶ W-2 Instruction.pdf  

M anual Install  
If the user encounters errors during the installation, complete the following steps to manually install Employee 

E-Mail Suite: 

1. Contact support@integrity-data.com to receive the manual install files for the product(s). 

2. Navigate to the Data folder (C:\Program Files\Microsoft Dynamics\GP2013\Data) create the following 

folders. 

a. EES 

b. W2-Attach 

3. Copy and paste the following files into the appropriate file locations. 

GP Folder (C:\Program Files\Microsoft Dynamics\GP2013) 

¶ EES.cnk  

¶ EES.chm  

¶ Application.EmployeeEmailSuite.dll 

¶ IDA6537.cnk  

¶ Application.IntegrityDataActivation.dll  

¶ Integrity.Registration.Constructor.dll  

¶ itextsharp.dll  

¶ Integrity.Email.Addin.dll  

¶ Microsoft.Office.Interop.Outlook.dll  

¶ Integrity.Registration.Addin.dll  

Documentation Folder (C:\Program Files\Microsoft Dynamics\GP2013\Documentation) 

¶ Employee E-Mail Suite GP 2013 User Guide.pdf  

mailto:support@integrity-data.com
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W2-Attach Folder (C:\Program Files\Microsoft Dynamics\GP2013\Data\W2-Attach) 

¶ W-2 Instruction.pdf 

 

4. Edit the Dynamics.exe.config 

Send support@integrity-data.com your dynamics.exe.config file and reference needing help manually 

updating the Dynamics.exe.config file to manually install Employee E-Mail Suite and we will edit the 

file and send it back to you. 

5. Launch Microsoft Dynamics GP. 

6. Login as the ¬system administrator­ for each company to create the SQL Server components. 

7. Add a registry key 

a. For 32 bit machines under HKEY_LOCAL_MACHINE > SOFTWARE  create key 

IntegrityEmailSuite ± see screenshot for 32 bit machine 

For 64 bit machines create IntegrityEmailSuite key under WOW64Node ± see screenshot for 

64 bit machine 

b. Under IntegrityEmailSuite create key GP2013 

64 bit screenshot 

 

32bit Screenshot 

mailto:support@integrity-data.com
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c. Add new string value Path 

 
d. Modify value - C:\Program Files (x86)\Microsoft Dynamics\GP2013\Data\EmailSuite 
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Microsoft Outlook  
If Microsoft Outlook will be used to send the Employee E-Mail Suite or the E-Mail W-2 Statements file to 

employees and track returned e-mails. The Integrity E-Mail AddIn must be installed.  See further information 

below for installing Integrity E-Mail AddIn Install. 

If the company would like the statement(s) to be sent from a ¬general payroll­ Outlook account and not from a 

payroll clerk­s personal Outlook account it is recommended to set up Multiple Outlook profiles. 

Multiple Outlook Profile  
Setting up a separate Network account and Outlook profile allows the company to send Employee E-Mail Suite 

or E-Mail W-2 Statements through a ¬general payroll­ Outlook account instead of using the payroll clerk­s 

personal Network account and Outlook profile.  Contact your IT Department for details on setting up a 

separate Network account and Outlook profile.  Integrity Data does not support Microsoft Outlook 

functionality .   

If the user creates a ¬general payroll­ Outlook profile it is important to verify Microsoft Dynamics GP is 

connected to the correct Outlook profile.  The Employee E-Mail Suite or E-Mail W-2 Statements will be sent 

from the Outlook profile connected to Microsoft Dynamics GP. 

Integrity E -Mail Addin  Install  
If Microsoft Outlook will be used to send the Employee E-Mail Suite or the E-Mail W-2 Statements file to 

employees and track returned e-mails then the Integrity E-Mail AddIn is required for Employee E-Mail Suite. 

The AddIn file must be installed on the client machine sending the e-mails.  This file enables the Trust Center 

Programmatic Access Security within Microsoft Outlook to function under the recommended settings.  The 

user will no longer receive the message: A program is trying to send an e-mail message on your behalf.  If this is 

unexpected, click Deny and verify your antivirus software is up-to-date. 
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Install Notes   
Prior to installing: 

¶ Confirm users are logged out of Microsoft Outlook 

¶ The install can be ran as the administrator or as the user by right clicking and selecting run as 

administrator. 

To install the Integrity E-Mail Addin the Addin must be downloaded from our website and installs processed on 

the Machine(s) sending e-mails.   

1. Right click the Outlook Setup.exe file and select run as Administrator. 

2. Complete the steps in the wizard. 

 

http://www.integrity-data.com/hrp/product-download-form/0310360942-2/


 

P a g e 17 | 98 
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3. Launch Microsoft Outlook. 

4. Select File > Options > Addin 

5. Validate the Integrity Email Companion Add-In is displayed under the Active Application Add-Ins. 
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Mail Server Setup  
Employee E-Mail Suite is designed to send mass amounts of e-mails.  Ensure the mail sever will allow the client 

to send the maximum amount of e-mails for the payroll process. 

Microsoft Exchange Setups for  Employee E -Mail Suite  
Employee E-Mail Suite is designed to send mass amounts of e-mail.  If the user is running Microsoft Outlook 

connected to a Microsoft Exchange Server then certain settings to the client Microsoft Outlook are needed to 

ensure all the desired e-mails are sent.  Keep in mind that turning 

the cache off, the user cannot use the client junk mail filter for 

their anti -spam and the user will need to rely on their centralized 

network anti -spam application. 

To adjust the settings within Microsoft Outlook: 

1. Navigate to Tools > Account Settings 

2. Double-click the Microsoft Exchange Name on the E-mail tab 

3. Within the Change E-mail Account window unmark the ®Use Cached Exchange Mode¯ 

4. Select the More Settings¤ button 

 

5. Within the Microsoft Exchange window, select the Connection tab 

6. Unmark ®Connect to Microsoft Exchange using HTTP¯ checkbox 

The user is not required to use 

Microsoft Exchange Server. 
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7. Click OK to close the Microsoft Exchange window 

8. Close the Change E-mail Account and Account Settings windows 

9. Restart Microsoft Outlook 
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Set Up Adobe Writer for Employee E -Mail Suite  
In order for the system to create the e-mail statements PDF file, the ®Rely on system fonts only; do not use 

document fonts¯ option must be unchecked on the Adobe PDF Printing Preferences window.  If the option is 

checked, the user will receive error messages and will not be able to send the e-mail statement PDF file.  For 

steps to unmark this option, review our Knowledge Base article: http://www.integrity -data.com/faq-items/kb-

prevent-postscript-error-message/. 

http://www.integrity-data.com/faq-items/kb-prevent-postscript-error-message/
http://www.integrity-data.com/faq-items/kb-prevent-postscript-error-message/
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Registration  
The system will automatically activate the product during the login process.  If the activation was successful, 

the user will not receive any messages.  However, if the activation process was unsuccessful the user will 

receive a message.  If the activation process fails the user will need to open the Activation Manager window to 

activate the product. 

Activation Manager Window  
Microsoft Dynamics GP > Tools > Setup > System > Activation Manager 

 

The Site Name defaults from the session information on the About Microsoft Dynamics GP window. 

From the Product drop-down list the user may select the product they wish to activate and review product 

information.  Once the product is selected the following fields will display: 

¶ Installed Version ± Current version number installed. 

¶ Enhancement Plan Date ± Date of the enhancement plan expiration. 

¶ Activation Status ± Current status of the product. 

o Permanent ± Product has been purchased. 

o Trial ± Product has been issued a trial period. 

o Deactivated ± Product has been deactivated. 

¶ Current Employees ± This count defaults from the session information on the About Microsoft 

Dynamics GP window.  The count does not include inactive employees or employees in a Test or 

Historical company.  If the current employee count is incorrect validate Test or Historical companies 

are named correctly. 

¶ Employees Allowed ± The number of employees allowed before the product will be inactivated.  If the 

Current Employees exceeds the Employees Allowed the system will deactivate the product. 

The scrolling window contains a list of all companies.  By default the product is active for all companies.  If the 

user would like to inactivate a company unmark the company checkbox. 
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The Auto Activation option may be selected if the user receives a message at login stating the product is not 

activated.  When the user selects the Auto Activation option the system will attempt to automatically activate 

the product.  Once the Auto Activation process is complete the system will display the Activation Messages.  

For a detailed list of activation messages see the Activation Manager Messages section. 

The Manual Activation option is used to manually enter a token.  The user would only manually enter a token 

if they were sent a token by Integrity Data. 

Select the OK button to close the window. 

Test and/or Historical Companies  
Registration will not count the active employees in Test or Historical company databases if the Company 

Name is named correctly, specifically at the end of the Company Name the user must append the following: 

®<TEST>¯ or ®<HISTORICAL>¯.  See examples below: 

¶ Dextordinary, Inc. <TEST> 

¶ Dextordinary, Inc. <HISTORICAL> 

To access and modify the Company Name open the Company Setup window via Microsoft Dynamics GP > 

Tools > Setup > Company > Company when logged into the Test or Historical Company that needs modified. 
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Security Settings  
The Security Task Setup window may be used to grant or restrict access to the Employee E-Mail Suite windows.  

To open the window, select the Microsoft Dynamics GP menu, select Tools, select Setup, select System, select 

Security Tasks and enter the system password. 

1. Select the appropriate Task items.  To identify the appropriate task item complete the steps below: 

Å Open the User Security Setup window (Microsoft Dynamics GP > Tools > Setup > System > 
User Security), select the appropriate user and make a note of the Security Role ID assigned to 
the user. 

Å Open the Security Role Setup window (Microsoft Dynamics GP > Tools > Setup > System > 
Security Roles), select the Role ID that has been assigned to the user and make note of the 
Security Task ID assigned to the Role.  Use this Task ID to grant security to the Employee E-
Mail Suite. 
NOTE: The most common Task ID used is TRX_PAYRL_004 ± Print Payroll Checks 

2. Select Employee E-Mail Suite for the Product. 

3. Select Windows for the Type and select 3rd Party for the Series. 

4. Use the Access List to grant or restrict access to individual items. 

¶ To grant or restrict access to an item for this Task ID, click the checkbox to mark or unmark 
the item. 

¶ Click the Mark All button to grant access to all items in the list or click the Unmark All button 
to restrict access to all items in the list. 

5. Click File > Print to print the Security Task Setup Report for the selected Task ID. 

6. Choose OK to save your changes. 

 

Employee E -Mail Suite > Windows > 3rd Party > Access List  

¶ 1095-C Export 

¶ APR Main Menu 

¶ E-Mail Earnings Statements 

¶ E-Mail Suite Setup 

¶ Password Setup 

¶ Registration ± EES 

¶ E-Mail W-2 Statements 

¶ Manage W-2 Recipients 

Employee E -Mail Suite > Reports > 3rd  Party > Access List  

¶ Earnings Statement Exceptions 

¶ EES 1095C Status Report 

¶ EES Error Report  

¶ EES Missing Email Report 

¶ Earnings Statement Exceptions 

¶ EES Error Report 

¶ EES Missing Email Report 

¶ E-Mail W2 Recipients 
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¶ E-Mail W2 Statements 

¶ W-2 Employee Copy 2 

¶ W-2 Employee Copy B 

¶ W-2 Employee Copy C 

¶ W-2 Employee Copy D 
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Direct Deposit Setup  
Microsoft Dynamics GP > Tools > Setup > Payroll > Direct Deposit 

The Earnings Statement Print option on the Direct Deposit Setup window needs to be set to ®Separate From 

Checks¯ in order for E-Mail Earnings Statements to function properly. 
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Introduction to Employee  E-Mail Suite  
Organizations are increasingly moving toward payroll processing using Direct Deposit.  The E-Mail Earnings 

Statements extends the payroll process functionality of Microsoft Dynamics GP to support the e-mailing of 

Earnings Statements as an added option during the print checks portion of the payroll process. 

The system will allow the user to: 

¶ Specify setup options for employees to receive e-mail earnings statements; 

¶ Add employees to an E-Mail Exceptions Report; 

¶ Password protect the e-mailed earnings statements (up to 15 characters); 

¶ Validate employees address ID on the Missing E-Mail List Report; 

¶ Generate individual earnings statements for employees and 

¶ E-Mail the statements to employees. 

The user will complete the following setup options: 

¶ E-Mail Configuration information 

o E-Mail Method 

o Subject Line 

o E-Mail Body 

o Blind Carbon Copy 

o Password 

o PDF file location 

¶ Employee Exceptions  

o Employee ID 

o Employee Name 

o E-Mail Address 

E-Mail Earnings Statements will process if the following conditions are met: 

¶ The Employee E-Mail Suite is installed and registered; 

¶ The user has selected the Activate E-Mail Earnings Statements checkbox; 

¶ The employee has an e-mail address assigned on the Internet Information window; 

¶ Direct deposit must be active and setup for the employee and 

¶ The employee must be included in the payroll run and not appear on the Exception List Report. 
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Internet Information Window  
Cards > Payroll > Employee > Select Employee > Address ID field > Internet Addresses button  

 

The Internet Information window allows 

the user to enter one or more e-mail 

addresses for each employee based on an 

address ID.  Employee E-Mail Suite will only 

use the e-mail address that is associated to 

the address ID code that is in the Address 

ID field on the Employee Maintenance 

window. 

 

Assign an E -Mail Address to an  Address ID  

¶ Select the Internet Addresses button  on the Employee Maintenance window 

¶ Enter the E-mail address in the E-mail field, within  the Internet Information section 

¶ Save and validate the Address ID on the Employee Maintenance window 

  

If the Address ID on the Employee Maintenance window is 

not associated with an e-mail address on the Internet 

Information window, the employee will appear on the 

Missing E-Mail List Report. 
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Assign Multiple E -Mail Addresses to an Employee  
If an employee has more than one e-mail address, the E-Mail Earnings Statement will only be e-mailed to the 

address ID defined on the Employee Maintenance window.  The following is specifics on how multi e-mail 

addresses process. 

 

For example, Ackerman has two address IDs, one PRIMARY and one SECONDARY.  Within the Internet 

Information window, the address IDs are as follows: 

PRIMARY Address ID = e-mail address ackerman@fabrikam.com 

SECONDARY Address ID = e-mail address pilarackerman@testcompany.com 

In the above Employee Maintenance window, Ackerman has the PRIMARY Address ID selected.  At the time 

the E-Mail Earnings Statements sends the e-mail, the system will use the e-mail Address associated to the 

PRIMARY Address ID that is ackerman@fabrikam.com. 

If the employee wants the E-Mail Earnings Statements sent to pilarackerman@testcompany.com, the user 

must change the Address ID to SECONDARY on the Employee Maintenance window, NOT on Internet 

Information window. 

When using Microsoft Outlook as your e-mail method, if the employee wants their Earnings Statement sent to 

multiple e-mail addresses, it is an option to enter both addresses into the e-mail field separated by a semi-

colon.  An example of this would be packerman@fabrikam.com;packerman@live.com. 

mailto:packerman@fabrikam.com;packerman@live.com











































































































































